[Webkit-unassigned] [Bug 77892] New: Give a name to attributes that might be invalid and needing updates

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 6 12:06:38 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=77892

           Summary: Give a name to attributes that might be invalid and
                    needing updates
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P4
         Component: XML DOM
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: cmarcelo at webkit.org
                CC: darin at apple.com, rniwa at webkit.org


While working on making NamedNodeMap a simple wrapper to Element, I noticed that some functions want to access attribute storage without updating invalid attributes (Style / SVG animations attributes can be marked as invalid). For example, we have hasAttributes() and hasAttributesWithoutUpdate(). The last one means no update of eventually invalid attributes will take place.

"WithoutUpdate" is too vague. Ryosuke Niwa proposed in IRC we could try to name those "special" attributes:

16:41 < cmarcelo> rniwa: hasAttributesWithoutUpdatingInvalidOnes()? I wouldn't want to mention the list explicitly, what if it 
                  changes.
16:42 < rniwa> cmarcelo: that's a good point
16:42 < rniwa> cmarcelo: maybe we need to give a name to the group of attributes that need to be dynamically updated
16:42 < rniwa> cmarcelo: maybe something like "RendererDependentAttribute"?
16:42 < rniwa> cmarcelo: or LayoutDependentAttributes?
16:42 < rniwa> cmarcelo: or DynamicAttribute?
16:43 < rniwa> cmarcelo: I like the last one least since every attribute is "dynamic" to some extent
16:43 < rniwa> cmarcelo: alas I don't like the fact seemingly generic word "update" is associated with a particular type of update 
               here.
16:44 < cmarcelo> rniwa: I understand. Having a clear name for them would help a lot.
16:44 < rniwa> cmarcelo: yeah but maybe it's fine to keep "WithoutUpdate" until we agree on some good name for it

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list