[Webkit-unassigned] [Bug 77864] [Qt] Initial implementation of accessibility support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 6 07:05:00 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=77864





--- Comment #10 from Simon Hausmann <hausmann at webkit.org>  2012-02-06 07:05:00 PST ---
(From update of attachment 125635)
View in context: https://bugs.webkit.org/attachment.cgi?id=125635&action=review

>> Source/WebKit/qt/Api/qwebviewaccessible_p.h:83
>> +    QWebViewAccessible(QWebView* view);
> 
> The parameter name "view" adds no information, so it should be removed.  [readability/parameter_name] [5]

So the meaning of this warning from the style queue is that you should simply remove the view parameter name, i.e.

    QWebViewAccessible(QWebView*);

(and you can use the parameter in the _implementation_ if you need it of course)

The rationale is that the "View" part of the type name is "redundant" with the "view" parameter name, it is a view anyway.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list