[Webkit-unassigned] [Bug 77551] [GTK] Fix xrefs after installing API documentation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 6 00:37:00 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=77551





--- Comment #7 from Martin Robinson <mrobinson at webkit.org>  2012-02-06 00:37:00 PST ---
(From update of attachment 124957)
View in context: https://bugs.webkit.org/attachment.cgi?id=124957&action=review

Nice stuff! I have just a few suggestions for moving things around.

> Tools/GNUmakefile.am:328
> +	$(srcdir)/Tools/gtk/generate-gtkdoc --rebase

I think this should happen automatically when --skip-html is not passed to generate-gtkdoc. Either that or you should add --skip-rebase to generate-gtkdoc and make sure to pass it in the build scripts.

> Tools/gtk/common.py:90
> +def xref_deps(xref_dep_packages):
> +    def package_prefix(package):
> +        process = subprocess.Popen(['pkg-config', '--variable=prefix', package],
> +                                   stdout=subprocess.PIPE)
> +        stdout = process.communicate()[0]
> +        if process.returncode != 0:
> +            return None
> +        return stdout.strip()
> +
> +    deps = []

I think odds are low that we are ever going to use xref_deps in any other file. I would keep package_prefix here and just call it something like prefix_of_pkg_config_file. I'd move xref_deps to generate-gtkdoc and call it get_gtkdoc_module_paths.

> Tools/gtk/common.py:103
> +def gtk_version(pkg_config_path):

Might want to name this to gtk_version_of_pkg_config_file.

> Tools/gtk/generate-gtkdoc:106
> +        'xref_deps' : common.xref_deps(xref_deps),

Do you mind changing this argument name to cross_reference_deps? I know it's a bit obtuse, but cross_reference seems a little clearer than xref here.

> Tools/gtk/generate-gtkdoc:140
> +    if '--rebase' not in sys.argv:
> +        print "Generating WebKit1 documentation..."
> +        saw_webkit1_warnings = generate_doc(pkg_config_path, get_webkit1_options(common.gtk_version(pkg_config_path)))
> +    else:
> +        print "Rebasing WebKit1 documentation..."
> +        rebase_doc(pkg_config_path, get_webkit1_options(common.gtk_version(pkg_config_path)))

I think it makes sense to just get the options once here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list