[Webkit-unassigned] [Bug 104354] IndexedDB: Don't use strings to represent serialized values

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Dec 15 07:39:23 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=104354





--- Comment #16 from Michael Pruett <michael at 68k.org>  2012-12-15 07:41:42 PST ---
(In reply to comment #15)
> (From update of attachment 178915 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=178915&action=review
> 
> (It looks like a couple of my comments were gone away...)
> 
> > Source/WebCore/bindings/js/SerializedScriptValue.h:107
> > +    static PassRefPtr<SerializedScriptValue> createFromWire(const Vector<uint8_t>& data)
> 
> It's a bit confusing that there are two createFromWire()s. Shall we rename the method?

Sure, I'll rename it to createFromWireBytes().

> > Source/WebCore/bindings/js/SerializedScriptValue.h:112
> > +    const Vector<uint8_t>& toWireBytes() const { return m_data; }
> 
> Is this correct? You're implementing toWireBytes() in the cpp file too.

Yes I believe this is correct. The toWireBytes() method is defined in the header file for the JSC SerializedScriptValue but in the source file for the V8 SerializedScriptValue.

> > Source/WebCore/bindings/v8/SerializedScriptValue.cpp:2326
> > +    return result;
> 
> Can we avoid copying the vector ?

I don't think so, but the copying that is now happening here used to happen in encodeString(), so I don't think there's any change.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list