[Webkit-unassigned] [Bug 104377] [sh4] Implement add64 for SH4 assembler after r136601

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 11 03:15:54 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=104377





--- Comment #3 from Julien Brianceau <jbrianceau at nds.com>  2012-12-11 03:18:17 PST ---
(From update of attachment 178484)
View in context: https://bugs.webkit.org/attachment.cgi?id=178484&action=review

>> Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:411
>> +        m_assembler.loadConstant(reinterpret_cast<uint32_t>(address.m_ptr), scr1); // src1 = int64 address
> 
> In WebKit you don't need to explain trivial facts :) Too much comments makes the code less readable.
> See http://www.webkit.org/coding/coding-style.html comments section.

Ok, I'll submit a new patch

>> Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:416
>> +        m_assembler.loadConstant(reinterpret_cast<uint32_t>(address.m_ptr), scr1); // src1 = int64 address
> 
> I am not sure how SH4 works, but if this requires a memory load, a third scratch register could be used to store the address of int64. I don't know you have a third scratch, so this might be unavoidable.

Unfortunately, there are only 2 scratch registers for sh4 JIT yet (see claimScratch() implementation)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list