[Webkit-unassigned] [Bug 104427] WebViewClient::didHandleGestureEvent needs to distinguish the case if the event is processed or swallowed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 10 14:36:58 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=104427





--- Comment #6 from Tien-Ren Chen <trchen at chromium.org>  2012-12-10 14:39:22 PST ---
(In reply to comment #5)
> (From update of attachment 178325 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=178325&action=review
> 
> > Source/WebKit/chromium/public/WebViewClient.h:148
> > +    enum EventStatus {
> 
> nit: It feels like this enum would be better at the top-level.  WebViewClient is already a big interface.

Do you mean move to the top-level and also to a separate header?
My thought is that put it under WebViewClient is good for namespace management. WebKit is probably a bigger interface than WebKit::WebViewClient right? :)

> > Source/WebKit/chromium/public/WebViewClient.h:149
> > +        EventStatusBubbledUp,
> 
> nit: Another name for EventStatusBubbledUp would be EventStatusUnprocessed or EventStatusNotProcessed, right?
> Such a name might be easier to understand.  It was not obvious to me that "bubbled up" meant that WebKit
> didn't handle the event.

Got it. Will change.

> Q: Are there cases where the event might get handled, but still propagate to another handler that would
> then cancel further event propagation?

I don't think so. If that's the case then we also need to move the didHandleGestureEvent hook point.
Personally I don't like the hook approach. A cleaner way would be looking at the return value from WebViewImpl::handleInputEvent. However I don't know what will be the side-effects if I change it that way.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list