[Webkit-unassigned] [Bug 103642] Add support for generic types in arrays and sequences to the code generators

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 4 02:46:50 PST 2012


--- Comment #11 from Adam Bergkvist <adam.bergkvist at ericsson.com>  2012-12-04 02:49:15 PST ---
(In reply to comment #10)
> (From update of attachment 177263 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=177263&action=review
> Looks good to me.
> > Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:3076
> > +sub GetNativeInnerVectorType
> Shall we rename it to GetRefPtrNativeType() ?

This sub routine is used to get the Vector inner type for primitive types and String as well (when used together with the old toNativeArray) so it shouldn't have "RefPtr" in the name. I renamed it to GetNativeVectorInnerType() since I thought that it might be more descriptive.

Thank you for reviewing.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list