[Webkit-unassigned] [Bug 103642] Add support for generic types in arrays and sequences to the code generators
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Dec 2 16:04:41 PST 2012
https://bugs.webkit.org/show_bug.cgi?id=103642
--- Comment #8 from Kentaro Hara <haraken at chromium.org> 2012-12-02 16:07:03 PST ---
(From update of attachment 176978)
View in context: https://bugs.webkit.org/attachment.cgi?id=176978&action=review
Thanks for updating the patch. Almost looks OK.
> Source/WebCore/bindings/js/JSDOMBinding.h:416
> + Vector<RefPtr<T> > toHostObjectArray(JSC::ExecState* exec, JSC::JSValue value, T* (*toT)(JSC::JSValue value))
toRefPtrNativeArray() might be a better name, as this is just another version of toNativeArray().
> Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:3070
> + return "Vector<" . GetNativeInnerVectorType($arrayOrSequenceType) . ">" if $arrayOrSequenceType;
Can't you use GetNativeType() ?
> Source/WebCore/bindings/v8/V8Binding.h:211
> + Vector<RefPtr<T> > toHostObjectArray(v8::Handle<v8::Value> value)
toRefPtrNativeArray() might be a better name.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list