[Webkit-unassigned] [Bug 105885] New: [WK2] Rename SetFrameInViewSourceMode to SetMainFrameInViewSourceMode

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 31 06:02:41 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=105885

           Summary: [WK2] Rename SetFrameInViewSourceMode to
                    SetMainFrameInViewSourceMode
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit2
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: cgarcia at igalia.com


Right after landing r138593 I've noticed a side effect. Something as easy as:

webkit_web_view_new ()
webkit_web_view_set_view_mode (SOURCE);
webkit_web_view_load_uri ();

doesn't work, and the page is loaded in web mode. the problem is that at that point the main frame proxy hasn't been created yet. Since what we want is actually to change only the main frame view suorce mode, we could rename SetFrameInViewSourceMode to SetMainFrameInViewSourceMode and we don't need a frameID anymore. The code is also more simple.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list