[Webkit-unassigned] [Bug 103510] Reduce the children repaints when moved multiple times during the layout
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Dec 4 10:16:28 PST 2012
https://bugs.webkit.org/show_bug.cgi?id=103510
Darin Adler <darin at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #177453|review? |review+
Flag| |
--- Comment #17 from Darin Adler <darin at apple.com> 2012-12-04 10:18:54 PST ---
(From update of attachment 177453)
View in context: https://bugs.webkit.org/attachment.cgi?id=177453&action=review
> Source/WebCore/rendering/RenderFlexibleBox.cpp:338
> + ChildrenFrameRects childrenOldRects;
> + appendChildrenFrameRects(childrenOldRects);
> layoutFlexItems(*m_orderIterator, lineContexts);
It’s strange that layoutFlexItems receives the iterator as an argument, but appendChildrenFrameRects and repaintChildrenDuringLayoutIfMoved both get the iterator directly from the data member. The three functions should do this consistently.
> Source/WebCore/rendering/RenderFlexibleBox.cpp:396
> +}
I think we should add this here:
ASSERT(childIndex == childrenOldRects.size());
> Source/WebCore/rendering/RenderFlexibleBox.h:81
> + typedef Vector<LayoutRect, 8> ChildrenFrameRects;
Needs a comment explaining where the number 8 came from.
I think the name ChildFrameRects would be better. Since rects is plural, children doesn’t also need to be plural. In English it would be "child frame rectangles" not "children frame rectangles".
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list