[Webkit-unassigned] [Bug 103772] Teach OwnPtr and RefPtr to understand Arena'd objects

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 3 11:07:13 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=103772





--- Comment #18 from Julien Chaffraix <jchaffraix at webkit.org>  2012-12-03 11:09:36 PST ---
(In reply to comment #17)
> (In reply to comment #16)
> > It's probably more interesting to add RefPtr support and use that with RenderLayer.  RenderObject is extra tricky because of RenderWidget, as well as the fact that we are currently using a union to store the RenderObject* on Node (the RareData optimization).
> 
> I was confused.  RenderLayer is not ref-counted.  I'm not sure OwnPtr is even a win there, since the code seems to imply that it's only safe to call destroy() from inside RenderLayerModeObject::destroyLayer.

I would still support doing the change for the sake of using more readable / better patterns in the render tree. Note that another way to switch RenderLayer to OwnPtr is to fix bug 87523. It's more of an experiment but it would make the move trivial.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list