[Webkit-unassigned] [Bug 91214] [EFL] Add WebMemorySampler feature.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Aug 29 07:32:51 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=91214
--- Comment #49 from Kenneth Rohde Christiansen <kenneth at webkit.org> 2012-08-29 07:32:54 PST ---
(From update of attachment 161218)
View in context: https://bugs.webkit.org/attachment.cgi?id=161218&action=review
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:82
> +static inline void appendMemoryStats(WebMemoryStatistics& webKitMemoryStats, const String& key, size_t value)
Statistics?
Why webKitMemoryStats and not just statistics... the class name already makes it clear what it is
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:86
> +{
> + webKitMemoryStats.keys.append(key);
> + webKitMemoryStats.values.append(value);
> +}
This methods seems a bit useless.
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:88
> +static ApplicationMemoryStats sampleApplicationMalloc()
is malloc really the best word? Especially given that this is not tied to the malloc call?
sampleMemoryAllocatedForApplication ?
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:93
> + FILE* fMemoryStatus = fopen(processPath, "r");
Why not statmFileDescriptor
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:97
> + applicationStats.totalProgramSize = getToken(fMemoryStatus).toInt();
nextToken seems like a better name
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:104
> + applicationStats.dirtyPageSize = getToken(fMemoryStatus).toInt();
> + fclose(fMemoryStatus);
add a newline before fclose to make it easier to spot
> Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:124
> +WebMemoryStatistics WebMemorySampler::sampleWebKit() const
WebKit is the project name and the name of the API's. Maybe sampleWebRuntime() makes more sense?
> Source/WebKit2/UIProcess/API/efl/ewk_context.cpp:90
> + static bool memorySampler = false;
memory sampler doesn't sounds like a "booload" to me... sampleMemory?
> Source/WebKit2/UIProcess/API/efl/ewk_context.cpp:91
> + static const char environMemorySampler[] = "MEMORY_SAMPLER";
environ? enviromentVariable? or ?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list