[Webkit-unassigned] [Bug 95266] New: check-webkit-style gets confused when a function returns PassRefPtr

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 28 16:59:29 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=95266

           Summary: check-webkit-style gets confused when a function
                    returns PassRefPtr
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Tools / Tests
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: achicu at adobe.com


The following line confuses the style checker. I assume this is related to the patch context, as I cannot reproduce the issue without that specific patch.

PassRefPtr<CustomFilterParameter> StyleResolver::parseCustomFilterTransformParameter(const String& name, CSSValueList* values)

https://bugs.webkit.org/show_bug.cgi?id=71401#c8

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/css3..." exit_code: 1
Source/WebCore/css/StyleResolver.cpp:5264:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5273:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 2 in 20 files

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list