[Webkit-unassigned] [Bug 94724] [BlackBerry] Extend LayerFilterRenderer in preparation for CSS Shaders

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 24 07:01:38 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94724





--- Comment #2 from Arvid Nilsson <anilsson at rim.com>  2012-08-24 07:01:37 PST ---
(From update of attachment 160262)
View in context: https://bugs.webkit.org/attachment.cgi?id=160262&action=review

LGTM, but please remove copy/paste in favor of LayerRenderer::orthoMatrix()

> Source/WebCore/platform/graphics/blackberry/LayerFilterRenderer.cpp:240
> +static void orthogonalProjectionMatrix(TransformationMatrix& matrix, float left, float right, float bottom, float top)

This code is already available in LayerRenderer::orthoMatrix(), no need for copy/paste

> Source/WebCore/platform/graphics/blackberry/LayerFilterRenderer.h:48
> +    virtual void onCompletion() { }

The "on" prefix is not typically used in WebKit, instead they use the will/did/should or other prefixes. In this case, maybe a better name that doesn't even need a prefix can be made. The name is nothing to R- for, but it is unusual for the WebKit codebase.

Since the calling function is called cleanUp() maybe this could be called cleanUp() to, but I'm not sure. To me, it looks like the clean up performed is mostly related to restoring state, so maybe restoreState() or something along those lines would make sense.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list