[Webkit-unassigned] [Bug 93210] CSSParser: Move enumeration to a common place (StylePropertyShorthand)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 22 16:13:23 PDT 2012


Dean Jackson <dino at apple.com> changed:

           What    |Removed                     |Added
 Attachment #159704|review?                     |review-
               Flag|                            |

--- Comment #8 from Dean Jackson <dino at apple.com>  2012-08-22 16:13:20 PST ---
(From update of attachment 159704)
View in context: https://bugs.webkit.org/attachment.cgi?id=159704&action=review

I wonder if webkitAnimationShorthandForParsing() is a better name? It makes it clear why we have this (annoying) duplication. I don't have a strong opinion either way.

Otherwise, just some small fixes needed before r+.

> Source/WebCore/css/CSSParser.cpp:3064
> +    const WebCore::StylePropertyShorthand& animationProperties = WebCore::webkitAnimationShorthandNameLast();

Why do you need the WebCore:: here?

> Source/WebCore/css/CSSParser.cpp:3071
> +    ASSERT(numProperties == webkitAnimationShorthandNameLast().length());
> +    ASSERT(webkitAnimationShorthand().length() == webkitAnimationShorthandNameLast().length());

You could compare to the animationProperties local variable.

> Source/WebCore/css/StylePropertyShorthand.cpp:275
> +    static const CSSPropertyID animationPropertiesLast[] = {

Why not animationPropertiesNameLast to be consistent?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list