[Webkit-unassigned] [Bug 93496] [BlackBerry] Add RSS content handling support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 21 09:58:22 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=93496





--- Comment #7 from Lyon Chen <liachen at rim.com>  2012-08-21 09:58:16 PST ---
(In reply to comment #6)
> I am not sure that you need to do this, the PlatformBlackBerry.cmake change suggests you can leave the rss/ off.

Yes, forgot this.

> > Source/WebCore/platform/network/blackberry/rss/RSSFilterStream.cpp:62
> > +static inline bool isControlCharacter(int data)
> 
> I wonder if there is a stdlib function for this.

Somehow I forgot to remove it as it is not used now, I use isASCIIPrintable() in where it was used.

> > Source/WebCore/platform/network/blackberry/rss/RSSFilterStream.cpp:67
> > +static int isspaceSafe(int ch)
> 
> What is meant here by "Safe"?

The "Safe" means just the lowest byte is checked. But I agree it is not very descriptive and I am open to better names.

> 
> > Source/WebCore/platform/network/blackberry/rss/RSSFilterStream.cpp:117
> > +    for (size_t start = 0, delimiter = 0;delimiter != std::string::npos; start = delimiter + 1) {
> 
> Fix spacing please ; delimiter

Will change.

> 
> > Source/WebCore/platform/network/blackberry/rss/RSSFilterStream.cpp:326
> > +        || (!strcasecmp(language, "en-US")))
> 
> No need to wrap this line.

Will change.

> Please try to make all comments end with a period and start with a capital. Right now it is a bit inconsistent.

Will change.

> 
> > Source/WebCore/platform/network/blackberry/rss/RSSFilterStream.h:32
> > +        TYPE_UNKNOWN = 0,
> 
> The = 0 is not strictly needed.

It seems quite some enum in WebKit has the first value = 0 style. And in all my codes I use this style. So I am not sure whether I should change it. But if you feel remove this "= 0," is desired, I can remove it.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list