[Webkit-unassigned] [Bug 94478] Rename Gesture Events for Scrolling

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 11:39:52 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94478





--- Comment #2 from Robert Kroeger <rjkroege at chromium.org>  2012-08-20 11:40:28 PST ---
I had thought to change the implementation of these events in a similar but not exactly the same fashion. To be precise, I had thought of altering the implementation of EventHandler::handleGestureEvent to handle the respective scroll events like so:

ScrollBegin: latch a target node, set up for a scroll.

ScrollUpdate: actually scroll the latched node. (I think it is desirable to have flags on the event to control how bubbling is handled. I can imagine wanting both bubbled and non-bubbled ScrollUpdate events.)

ScrollEnd: clean up any latched state.

FlingStart: initiate a inertial scroll. With the presumption that the finger is no longer touching the screen during the fling.

So a touchscreen scroll in pseudo regex would look like this:

ScrollBegin ScrollUpdate* (ScrollEnd | FlingStart)

This seems a lot like: ScrollUnlatched ScrollLatched* ScrollByInertia except for the addition of ScrollEnd. Are you open to retaining it?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list