[Webkit-unassigned] [Bug 73819] [Gtk] Dojo toggle buttons should expose ROLE_TOGGLE_BUTTON not ROLE_PUSH_BUTTON

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 08:53:34 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=73819





--- Comment #26 from chris fleizach <cfleizach at apple.com>  2012-08-20 08:54:09 PST ---
(From update of attachment 159393)
View in context: https://bugs.webkit.org/attachment.cgi?id=159393&action=review

> Source/WebCore/accessibility/AccessibilityNodeObject.cpp:356
>          role = PopUpButtonRole;

It looks like this logic is duplicated 3 times (and seems likely to grow)
we should probably add a method (something like)

AccessibilityRole buttonRoleType() const;  

that will check ariaPressed() and ariaHasPopup()

> Source/WebCore/accessibility/AccessibilityObject.h:455
> +    virtual bool hasARIAPressed() const { return false; }

I don't know which naming is better (ariaHas or hasARIA), but we should probably stick with the precedent here (so maybe use ariaHasPressedState())

> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:1689
> +bool AccessibilityRenderObject::hasARIAPressed() const

this method should be in AccessibilityObject.cpp

> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:3148
> +        return ButtonRole;

another place to use that new method

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list