[Webkit-unassigned] [Bug 94478] New: Rename Gesture Events for Scrolling

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 07:06:46 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94478

           Summary: Rename Gesture Events for Scrolling
           Product: WebKit
           Version: 420+
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Event Handling
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: allan.jensen at nokia.com


When I looked at implementing support for the scrolling gesture in WebKit2 for Qt, I realized the names are rather unintuitively named.

Here is what they do as far as I can tell:
ScrollBegin: Scroll at the current positition unlatched.
ScrollUpdate: Scroll at the current position latched (this event must ALSO be used for the beginning of the scroll since only ScrollUpdate latches).
ScrollEnd: Perform animated kinetic Scroll from this point.

When reading them, it seems like you should start with a ScrollBegin, update with ScrollUpdate and end with ScrollEnd, but this will always be incorrect. If you want unlatched scrolling, you must always send ScrollBegin, you you want latched scrolling you must always use ScrollUpdate, and you should never send ScrollEnd, unless the wheel-event is synthetic and send from hardware that doesn't do the kenetic scrolling internally (which most does).

I suggest renaming them: ScrollUnlatched, ScrollLatched and ScollByInertia

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list