[Webkit-unassigned] [Bug 91912] Adding "all" to -webkit-user-select

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 16 15:16:41 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91912





--- Comment #30 from Alice Cheng <alice_cheng at apple.com>  2012-08-16 15:17:11 PST ---
(From update of attachment 158896)
View in context: https://bugs.webkit.org/attachment.cgi?id=158896&action=review

Thanks Ryosuke for your review, and I have my questions.

>> Source/WebCore/dom/Position.cpp:886
>> +    while (parent && Position::nodeIsUserSelectAll(parent)) {
> 
> Ditto about Position:: and needing a test.

I think it is tested in LayoutTests/editing/selection/user-select-all-selection.html, but I do need to modify that html to be more readable. Or is there an additional test needed?

>> Source/WebCore/page/EventHandler.cpp:442
>>          updateSelectionForMouseDownDispatchingSelectStart(innerNode, newSelection, WordGranularity);
> 
> Why don't we call this in updateSelectionForMouseDownDispatchingSelectStart instead of repeating it everywhere?

Because the VisibleSelection in updateSelectionForMouseDownDispatchingSelectStart is passed in as a constant reference, and therefore I cannot change it there. Do you want me to remove the const and call it there?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list