[Webkit-unassigned] [Bug 94182] [chromium] Implement Link Preview (a.k.a. on-demand zoom)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 16 11:30:30 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94182





--- Comment #4 from Alexandre Elias <aelias at chromium.org>  2012-08-16 11:31:01 PST ---
(From update of attachment 158702)
View in context: https://bugs.webkit.org/attachment.cgi?id=158702&action=review

> Source/WebKit/chromium/features.gypi:84
> +      'ENABLE_LINK_PREVIEW=1',

As I was saying earlier, before the confusing naming gets embedded into the code, can we rename this to "disambiguation popup"?

> Source/WebKit/chromium/public/WebInputEvent.h:382
> +    bool generatedByLinkPreview;

Here's a thought.  This value could be replaced by "float errorDistance;"  The browser could send down a value corresponding to basically the size of a finger and it could feed into the scoring function.  When the tap already has been disambiguated, the error can be set to zero.

> Source/WebKit/chromium/src/WebViewImpl.cpp:741
> +        score *= max((padding - (boundingBox.x() - touchPoint.x())) * divPadding, (float)0);

I think this code can be made more compact by using some of the fancier IntRect methods.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list