[Webkit-unassigned] [Bug 93609] Rename functions in the ARM port of DFG-JIT for better code readability.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 14 02:28:08 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=93609


Zoltan Herczeg <zherczeg at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #157738|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #6 from Zoltan Herczeg <zherczeg at webkit.org>  2012-08-14 02:28:38 PST ---
(From update of attachment 157738)
View in context: https://bugs.webkit.org/attachment.cgi?id=157738&action=review

> Source/JavaScriptCore/assembler/ARMAssembler.h:470
> -        void vsqrt_f64_r(int dd, int dm, Condition cc = AL)
> +        void vsqrtFloat64(int dd, int dm, Condition cc = AL)

Do not rename this, only remove the _r. There are other similar instances, probavbly a followup patch.

> Source/JavaScriptCore/assembler/ARMAssembler.h:475
> -        void vabs_f64_r(int dd, int dm, Condition cc = AL)
> +        void vabsFloat64(int dd, int dm, Condition cc = AL)

Ditto.

> Source/JavaScriptCore/assembler/ARMAssembler.h:480
> -        void vneg_f64_r(int dd, int dm, Condition cc = AL)
> +        void vnegFloat64(int dd, int dm, Condition cc = AL)

Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list