[Webkit-unassigned] [Bug 93464] New: Rename two methods of ImageSource in order to clarify the intention: frameDurationAtIndex() and frameIsCompleteAtIndex().

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 8 04:58:02 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=93464

           Summary: Rename two methods of ImageSource in order to clarify
                    the intention: frameDurationAtIndex() and
                    frameIsCompleteAtIndex().
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Images
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: luxtella at company100.net


There are three methods which can trigger image decoding:
ImageSource::createFrameAtIndex()
ImageSource::frameIsCompleteAtIndex()
ImageSource::frameDurationAtIndex()

frameIsCompleteAtIndex() and frameDurationAtIndex() make us confused because
both methods can trigger image decoding although the name of both methods do not
look so.
This patch renames frameDurationAtIndex() and frameIsCompleteAtIndex() to
frameDurationAtIndexDecodingIfNecessary() and
frameIsCompleteAtIndexDecodingIfNecessary() respectively.
BitmapImage has the wrappers of both methods, so this patch renames those
wrappers too.

It is a preparation patch for implementing an async image decoder.
Both methods are not plane getters, so developers need to be careful
when using these methods. Otherwise, sync or async image
decoding will be triggered, which is an unexpected behavior.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list