[Webkit-unassigned] [Bug 93127] Adding APIs to Chromium WebKit API to allow for creating and monitoring frame hierarchy.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 3 09:17:36 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=93127





--- Comment #3 from Adam Barth <abarth at webkit.org>  2012-08-03 09:17:35 PST ---
(From update of attachment 156390)
View in context: https://bugs.webkit.org/attachment.cgi?id=156390&action=review

> Source/WebKit/chromium/public/WebDocument.h:108
> +    WEBKIT_EXPORT WebElement createElement(const WebString&);

I'd name this parameter.  Presumable it's the tag name?

> Source/WebKit/chromium/src/WebFrameImpl.cpp:594
> +WebString WebFrameImpl::assignedName() const
> +{
> +    return m_frame->tree()->name();
> +}

Can we change these API names to match the WebCore names?  That might make your patch a bit harder to land...

> Source/WebKit/chromium/src/WebFrameImpl.cpp:2136
> +      m_client->didCreateFrame(this, webframe.get());

four-space indent

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list