[Webkit-unassigned] [Bug 84467] IndexedDB: cursor does not correctly iterate over keys added and removed during iteration

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 23 15:00:00 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=84467





--- Comment #2 from Alec Flett <alecflett at chromium.org>  2012-04-23 15:00:01 PST ---
(From update of attachment 138131)
View in context: https://bugs.webkit.org/attachment.cgi?id=138131&action=review

> Source/WebCore/platform/leveldb/LevelDBTransaction.cpp:417
> +            && (!m_dbIterator->isValid()

I find the logic of this very difficult to read - can you break at least the direction checks into a separate helper function? these:
    || (m_direction == kForward && m_comparator->compare(m_treeIterator->key(), m_dbIterator->key()) < 0)
    || (m_direction == kReverse && m_comparator->compare(m_treeIterator->key(), m_dbIterator->key()) > 0))

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list