[Webkit-unassigned] [Bug 81084] Fix rendering of replaced elements with relative dimensions within a table cell.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Apr 18 08:52:42 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=81084
Julien Chaffraix <jchaffraix at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #137524|review? |review+, commit-queue-
Flag| |
--- Comment #20 from Julien Chaffraix <jchaffraix at webkit.org> 2012-04-18 08:52:42 PST ---
(From update of attachment 137524)
View in context: https://bugs.webkit.org/attachment.cgi?id=137524&action=review
> Source/WebCore/rendering/RenderReplaced.cpp:562
> + bool hasRelativeDimensions = false;
> +
> + if (style->height().isAuto() || style->height().isPercent() || style->width().isAuto() || style->width().isPercent())
> + hasRelativeDimensions = true;
> +
> + return hasRelativeDimensions;
This could be simplified a lot:
return style->height().isAuto() || style->height().isPercent() || style->width().isAuto() || style->width().isPercent();
> LayoutTests/ChangeLog:34
> + * platform/wincairo/Skipped:
You can always re-organize the entries to avoid duplicated text. I find that it has the benefit of making the ChangeLog more cleaner and more readable (smaller).
> LayoutTests/platform/qt/fast/replaced/table-cell-width-percent-expected.txt:44
> +FAIL getWidth('input-image-td-width-percent') should be 100px. Was 530px.
Please consider filing a follow-up bug on having a test with some failing results.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list