[Webkit-unassigned] [Bug 69073] New: [EFL] Change one-letter parameter variable with WebKit coding Style.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 29 01:49:18 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69073

           Summary: [EFL] Change one-letter parameter variable with WebKit
                    coding Style.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit EFL
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: gyuyoung.kim at samsung.com
                CC: demarchi at webkit.org, gyuyoung.kim at webkit.org


As you know, EFL port has used one-letter parameter for public / private functions. But, this has be more difficult for other reviewers to review EFL patches as other efl coding style.

I would like to suggest two ideas for this bug.

1. Use meaningful variable instead of one-letter variable in both .h and .cpp files

2. Only use one-letter variable in public APIs definition. For example,

    ewk_view.h
        EAPI Eina_Bool    ewk_view_setting_scripts_can_close_windows_set(Evas_Object *o, Eina_Bool allow);

    ewk_view.cpp
        Eina_Bool ewk_view_setting_scripts_can_close_windows_set(Evas_Object* object, Eina_Bool allow)
        {
            EWK_VIEW_SD_GET_OR_RETURN(object, sd, EINA_FALSE);
            EWK_VIEW_PRIV_GET_OR_RETURN(sd, priv, EINA_FALSE);
            ...

I'd like to listen you guys opinions.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list