[Webkit-unassigned] [Bug 68610] Microdata: Basic implementation of document.getItems() method

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 28 00:14:12 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68610





--- Comment #5 from Arko Saha <nghq36 at motorola.com>  2011-09-28 00:14:11 PST ---
(In reply to comment #4)
Thanks for the review.

> Clearly, we need a test for this feature.

Done! Combined test-cases and code changes in a single patch.

> I'm not convinced that ItemNodeList is a good name for this class. It sounds too generic.
> 
> Now about MicroDataItemList?

Yes you are right ItemNodeList is generic class name, Changed the class name to MicroDataItemList.

> I'd like this function name to include microData somewhere.

Done! removeCachedItemNodeList() medthod renamed to removeCachedMicroDataItemList().

> Why should this function live in Node instead of Document?

I have placed getItems() method in Document so that they can use the caching mechanism already used by getElementsByClassName and getElementsByName. getElementsByClassName and getElementsByName were moved to Node some time back (https://bugs.webkit.org/show_bug.cgi?id=16511).

> I don't think we should be dispatching subtree modified here. As far as I understand it, this function is called in parseMappedAttribute, which means nothing in the DOM tree has changed. r- because of this.

Agreed! Modified the code so that it will only invalidate the MicroDataItemList cache while itemType attribte changed by JavaScript.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list