[Webkit-unassigned] [Bug 68595] [EFL] Add matrix list to reuse tile matrix for each different zoom level.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 23 17:15:20 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68595





--- Comment #5 from KwangHyuk <hyuki.kim at samsung.com>  2011-09-23 17:15:19 PST ---
> The idea sounds good, but the implementation needs some love. As we're trying  to adequate ourselves to WebKit's coding style, it would be really good if > these one or two-letter variables had proper names. There are many separate places which allocate and remove entries from the list, this code should all be put in single functions.

Ok, let me check. :-)

>> Source/WebKit/efl/ChangeLog:7
>> +        And then it will resue the tile matrix previously created by getting it from this matrix list.
>
> resue -> reuse

Ok, thank you for your correction.

>> Source/WebKit/efl/ewk/ewk_tiled_backing_store.c:119
>> +        Eina_Bool layout:1;
>
> Isn't it possible to use change.model here?

Good point.

>> Source/WebKit/efl/ewk/ewk_tiled_matrix.c:72
>> +Ewk_Tile_Matrix_Entry *ewk_tile_matrix_matrix_from_zoom_get(Ewk_Tile_Matrix *tm, float zoom);
>
> The implementation can be moved here and the function can be made static. "from_zoom" doesn't sound good in the name. Maybe just _ewk_tile_matrix_matrix_get, or _ewk_tile_matrix_get?

Make sense.

>> Source/WebKit/efl/ewk/ewk_tiled_matrix.h:33
>> +void ewk_tile_matrix_change_matrix(Ewk_Tile_Matrix* tm, float zoom);
>
> This name doesn't tell what the function is supposed to do. How about ewk_tile_matrix_zoom_level_set() or something along these lines?

Ok, I will try it. :-)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list