[Webkit-unassigned] [Bug 63502] [EFL] Add EflWidgetBackingStoreCairo

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 20 02:12:13 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63502





--- Comment #14 from EunMi Lee <eunmi15.lee at samsung.com>  2011-09-20 02:12:13 PST ---
(In reply to comment #12)
> (From update of attachment 98845 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=98845&action=review
> 

Kenneth, thanks for your review :)

> > Source/WebCore/platform/efl/EflWidgetBackingStoreCairo.cpp:42
> > +private:
> 
> When you make a private class it is common to have everything just public as it is protected anyway.

Ok, you are right, so I removed private keyword.

> 
> > Source/WebCore/platform/efl/EflWidgetBackingStoreCairo.cpp:49
> > +        int w = size.width();
> > +        int h = size.height();
> 
> We normally write things out, ie. width, height and not w, h
>

That codes are not used anymore, but I will be careful to use full word for variable's name.

> > Source/WebCore/platform/efl/EflWidgetBackingStoreCairo.cpp:81
> > +void WidgetBackingStore::scroll(const IntRect& scrollRect, const IntSize& scrollOffset)
> 
> Maybe const IntRect& areaToScroll, const IntSize& delta) ?

Yes, scrollRect means areaToScroll and scrollOffset means delta of scroll.
But, scroll function will be used at WebKit2's BackingStore and its parameters will be filled with updateInfo.scrollRect and updateInfo.scrollOffset.
So, I think current parameter name will be useful.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list