[Webkit-unassigned] [Bug 68212] re-name LayerChromium border functions to reflect that they are only for debug use

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 15 23:49:40 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68212





--- Comment #2 from James Robinson <jamesr at chromium.org>  2011-09-15 23:49:40 PST ---
(From update of attachment 107589)
View in context: https://bugs.webkit.org/attachment.cgi?id=107589&action=review

> Source/WebCore/platform/graphics/chromium/GraphicsLayerChromium.cpp:74
> -static void setLayerBorderColor(LayerChromium& layer, const Color& color)
> +static void setLayerDebugBorderColor(LayerChromium& layer, const Color& color)
>  {
> -    layer.setBorderColor(color);
> +    layer.setDebugBorderColor(color);
>  }
>  
> -static void clearBorderColor(LayerChromium& layer)
> +static void clearDebugBorderColor(LayerChromium& layer)
>  {
> -    layer.setBorderColor(static_cast<RGBA32>(0));
> +    layer.setDebugBorderColor(static_cast<RGBA32>(0));
>  }

I'm really deeply confused about why these functions exist - they seem pretty silly.  Why aren't we just calling the functions right on the layers?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list