[Webkit-unassigned] [Bug 68116] Tiered compilation heuristics do not account for value profile fullness

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 14 14:53:17 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68116


Oliver Hunt <oliver at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #107395|1                           |0
        is obsolete|                            |




--- Comment #4 from Oliver Hunt <oliver at apple.com>  2011-09-14 14:53:17 PST ---
(From update of attachment 107395)
View in context: https://bugs.webkit.org/attachment.cgi?id=107395&action=review

Basically okay, but it needs an actual changelog and can you convert the magic numbers into named constants?

Given you're adding a new cpp file you'll need to add it to GNUMakefile, JavaScriptCore.pro and CMakeLists.txt

> Source/JavaScriptCore/ChangeLog:7
> +

You do need an actual changelog entry you know :D

> Source/JavaScriptCore/jit/JIT.cpp:102
> -    Jump skipOptimize = branchAdd32(Signed, TrustedImm32(kind == LoopOptimizationCheck ? 1 : 30), AbsoluteAddress(&m_codeBlock->m_executeCounter));
> +    Jump skipOptimize = branchAdd32(Signed, TrustedImm32(kind == LoopOptimizationCheck ? 1 : 15), AbsoluteAddress(m_codeBlock->addressOfExecuteCounter()));

Ahhh magic numbers!!! L-( I have no idea what this number means -- can we hoist it into a named constant?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list