[Webkit-unassigned] [Bug 68037] Implement WebKit side of IDBFactory::databaseNames

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 14 11:04:18 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68037





--- Comment #8 from Joshua Bell <jsbell at chromium.org>  2011-09-14 11:04:19 PST ---
(In reply to comment #5)
> > > Source/WebCore/storage/IDBLevelDBCoding.cpp:810
> > > +    end.append("\x01"); // just after origin in collation order
> > 
> > I see what you mean about the sketchiness. Hans might know a better way.
> 
> I think this is fine. I'm not sure about the name though: encodeMaxKeyForOrigin(), since it's not really the max key for this origin, but rather the min key for the next one. Maybe you could just use encodeMinKeyForOrigin(origin + "\x01") where you use this?

Possible. I was trying to follow the model of the other LevelDB iterators, which generate a start key using encode() then a stop key using encodeMaxKey() - which is typically the MAX_INT64 value. I wanted to hide the min/max logic in the implementation in IDBLevelDBCoding rather than having IDBLevelDBBackingStore be aware of the storage details.

I will change the implementation to that (more readable)... but how about encodeStopKeyForOrigin() as a name?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list