[Webkit-unassigned] [Bug 68037] Implement WebKit side of IDBFactory::databaseNames

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 14 04:31:10 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=68037





--- Comment #5 from Hans Wennborg <hans at chromium.org>  2011-09-14 04:31:10 PST ---
(In reply to comment #3)
> > Source/WebCore/storage/IDBFactory.h:49
> > +class IDBFactory : public RefCounted<IDBFactory>, public ActiveDOMObject {
> 
> I'm not 100% sure that this won't cause problems but we'll see.  Actually, what prompted you to make this an ActiveDOMObject?

I'm curious about that too.

> > Source/WebCore/storage/IDBLevelDBCoding.cpp:810
> > +    end.append("\x01"); // just after origin in collation order
> 
> I see what you mean about the sketchiness. Hans might know a better way.

I think this is fine. I'm not sure about the name though: encodeMaxKeyForOrigin(), since it's not really the max key for this origin, but rather the min key for the next one. Maybe you could just use encodeMinKeyForOrigin(origin + "\x01") where you use this?

> 
> > Source/WebKit/chromium/src/IDBFactoryBackendProxy.h:-47
> > -    PassRefPtr<WebCore::DOMStringList> databases(void) const;
> 
> Hans, do you know any of the backstory here?

Sorry, no. I think that function has been sitting there since before I started on this.

> > LayoutTests/storage/indexeddb/factory-basics.html:36
> > +    // TODO: test indexedDB.cmp(key1, key2)
> 
> What's cmp?

It's this guy: http://dvcs.w3.org/hg/IndexedDB/raw-file/tip/Overview.html#widl-IDBFactory-cmp-int-any-first-any-second which we haven't implemented yet (crbug.com/92039).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list