[Webkit-unassigned] [Bug 67537] Implement a ProgressEvent constructor for JSC

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 7 11:09:08 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=67537


Sam Weinig <sam at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #106597|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #15 from Sam Weinig <sam at webkit.org>  2011-09-07 11:09:08 PST ---
(From update of attachment 106597)
View in context: https://bugs.webkit.org/attachment.cgi?id=106597&action=review

I think there should also be an object with a valueOf() function, but this looks much better.

> Source/WebCore/bindings/js/JSDictionary.cpp:40
> +static const double D64 = 18446744073709551616.0;

This should have a more descriptive name.

> Source/WebCore/dom/ProgressEvent.h:66
> +    ProgressEvent(const AtomicString& type, const ProgressEventInit& initializer);

initializer parameter names is not needed.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list