[Webkit-unassigned] [Bug 67176] JavaScriptCore does not have tiered compilation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 5 20:51:13 PDT 2011


--- Comment #37 from Gavin Barraclough <barraclough at apple.com>  2011-09-05 20:51:13 PST ---
> branchAdd32 should use scratchRegister not r11:
>     I renamed it to branchAdd32Absolute and moved it to the subclasses.

You forgot to remove branchAdd32 from MacroAssemblerX86Common.h!
Also branchAdd32Absolute should be named branchAdd32, other AbsoluteAddress'ed methods aren't named in this fashion.

I'm fine with the other changes / review push-back, r+ with MacroAssemblerX86Common::branchAdd32 removed, branchAdd32Absolute renamed to branchAdd32.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list