[Webkit-unassigned] [Bug 71110] Add per-script font preferences support in overridePreference

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 28 10:50:04 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=71110


Tony Chang <tony at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #112849|review?                     |review-
               Flag|                            |




--- Comment #3 from Tony Chang <tony at chromium.org>  2011-10-28 10:50:04 PST ---
(From update of attachment 112849)
View in context: https://bugs.webkit.org/attachment.cgi?id=112849&action=review

> Tools/ChangeLog:9
> +        // Set standard font for USCRIPT_ARABIC to Ahem.
> +        overridePreference("WebKitStandardFontMap", [ "2", "Ahem" ]);

I assume 2 is USCRIPT_ARABIC?  It would be nice if we could pass in strings (e.g., "arabic") instead of magic numbers.  For example, what if a port doesn't use ICU (it looks like wince and brewmp don't use icu)?

> Tools/DumpRenderTree/chromium/WebPreferences.h:52
> +    // Map of UScriptCode to font such as USCRIPT_ARABIC
> +    // to "My Arabic Font".
> +    WebKit::WebString standardFontMap[USCRIPT_CODE_LIMIT];

Can we use a HashMap instead of a statically allocated array?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list