[Webkit-unassigned] [Bug 71042] Don't use GOwnPtr for ref-counted objects

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 27 12:36:16 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=71042


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #112723|review?                     |review-
               Flag|                            |




--- Comment #3 from Martin Robinson <mrobinson at webkit.org>  2011-10-27 12:36:16 PST ---
(From update of attachment 112723)
View in context: https://bugs.webkit.org/attachment.cgi?id=112723&action=review

Thanks for the cleanup. Just a nit below.

> Source/WebCore/platform/graphics/gstreamer/GStreamerGWorld.cpp:91
> +    GstElement* p = 0;

We typically use full words for variable names in WebKit. If you want you call this videoSinkPtr or maybe we can consider adding a adoptOutPtr method to GRefPtr.

> Source/WebCore/platform/graphics/gstreamer/GStreamerGWorld.cpp:163
> +    GstElement* p = 0;

Ditto.

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:1013
> +    GstElement* p = 0;

Ditto.

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:1026
> +    GstElement* p = 0;

Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list