[Webkit-unassigned] [Bug 70572] Refactor OptionsObject.cpp

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 26 17:39:53 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=70572





--- Comment #4 from Kentaro Hara <haraken at chromium.org>  2011-10-26 17:39:53 PST ---
(In reply to comment #2)
> (From update of attachment 111890 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=111890&action=review
> 
> > Source/WebCore/bindings/v8/OptionsObject.h:54
> > +    bool getKeyValue(const String&, bool&) const;
> > +    bool getKeyValue(const String&, int32_t&) const;
> > +    bool getKeyValue(const String&, double&) const;
> > +    bool getKeyValue(const String&, String&) const;
> > +    bool getKeyValue(const String&, ScriptValue&) const;
> 
> Why not just call these functions "get" ?
> 
> > Source/WebCore/bindings/v8/OptionsObject.h:61
> > +    bool getKeyValueWithUndefinedOrNullCheck(const String&, String&) const;
> 
> getWithUndefinedOrNullCheck ?

Done and committed. Thanks!!

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list