[Webkit-unassigned] [Bug 70572] New: Refactor OptionsObject.cpp

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 20 19:14:23 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=70572

           Summary: Refactor OptionsObject.cpp
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: haraken at chromium.org
                CC: abarth at webkit.org, jorlow at webkit.org


For example, OptionsObject::getKeyBool() is an alias of OptionsObject::getKeyValue(const String& key, bool& value). We should remove OptionsObject::getKeyXXXX() (XXXX is some specific type) and unify them into OptionsObject::getKeyValue(const String& key, XXXX& value).

c.f. Corresponding JSC methods are unified into JSDictionary::convertValue(JSC::ExecState*, JSC::JSValue, XXXX&).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list