[Webkit-unassigned] [Bug 69821] Switch RegisterSizedBoolean/dfgConvertJSValueToInt32 return type to size_t

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 11 00:42:58 PDT 2011


--- Comment #3 from Filip Pizlo <fpizlo at apple.com>  2011-10-11 00:42:58 PST ---
(From update of attachment 110482)
Wouldn't it be better to use uintptr_t instead of size_t?  size_t implies that you're describing the size of something in memory.  uintptr_t implies any unsigned pointer-sized word for holding any kind of integer or pointer, and doesn't imply any meaning (unlike size_t).  It might be less confusing in this case, since these operations are pretty much never returning the size of things.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list