[Webkit-unassigned] [Bug 69690] DFG does not have flow-sensitive intraprocedural control flow analysis

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 10 15:06:01 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69690





--- Comment #30 from Gavin Barraclough <barraclough at apple.com>  2011-10-10 15:06:01 PST ---
(From update of attachment 110310)
View in context: https://bugs.webkit.org/attachment.cgi?id=110310&action=review

couple more comments

> Source/JavaScriptCore/dfg/DFGAbstractValue.h:63
> +            m_structure = reinterpret_cast<Structure*>(1);

The magic value '1' should be named, either behind a static const or an ifdef.

> Source/JavaScriptCore/dfg/DFGAbstractValue.h:235
> +        if (reinterpret_cast<uintptr_t>(m_structure) <= 1)

This should use 'isNeitherClearNorTop'.

> Source/JavaScriptCore/dfg/DFGAbstractValue.h:249
> +    bool isNeitherClearNorTop() const { return reinterpret_cast<uintptr_t>(m_structure) > 1; }

It would probably make the code more understandable to negate this - make this method isClearOrTop(), negate uses.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list