[Webkit-unassigned] [Bug 69690] DFG does not have flow-sensitive intraprocedural control flow analysis

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 8 11:28:40 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=69690





--- Comment #15 from Oliver Hunt <oliver at apple.com>  2011-10-08 11:28:40 PST ---
(From update of attachment 110265)
View in context: https://bugs.webkit.org/attachment.cgi?id=110265&action=review

Should use a typedef for bool (*predictionCheck)(PredictedType), getBytecodeBegin shouldn't be taking an OwnPtr*, but it looks like that has just  been moved from one place to another.

Other than those style quirks I can't see any obvious problems.

I am slightly concerned with the potential maintenance problems caused by separating type flow logic from codegen, especially given the vast amount of code duplication we currently have :-(

I do think Gavin should also look at this though.

> Source/JavaScriptCore/dfg/DFGBasicBlock.h:59
> +    static inline BlockIndex getBytecodeBegin(OwnPtr<BasicBlock>* block)
> +    {
> +        return (*block)->bytecodeBegin;
> +    }

This seems wrong, there's no transfer of ownership intended here, you should just be passing BasicBlock*

> Source/JavaScriptCore/dfg/DFGSpeculativeJIT32_64.cpp:350
> +void SpeculativeJIT::compileObjectEquality(Node& node, void* vptr, bool (*predictionCheck)(PredictedType))

Would be nice to have a typedef for bool (*predictionCheck)(PredictedType)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list