[Webkit-unassigned] [Bug 73185] [blackberry] Upstream BlackBerry porting of plugin framework

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 30 07:30:04 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=73185


Antonio Gomes <tonikitoo at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #117122|review?                     |review+
               Flag|                            |




--- Comment #21 from Antonio Gomes <tonikitoo at webkit.org>  2011-11-30 07:30:04 PST ---
(From update of attachment 117122)
View in context: https://bugs.webkit.org/attachment.cgi?id=117122&action=review

there are some nits, but it looks good r+.

Please fix them before landing :)

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:77
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

maybe we could make it a helper static local function: toPluginView (or a better name)?

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:84
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and use it here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:91
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:98
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:105
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:112
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:119
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:126
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:133
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:140
> +    PluginView* view = static_cast<PluginView*>(instance->ndata);
> +    PluginViewPrivate* viewPrivate = view->getPrivate();

... and here

> Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:156
> +NPSurface lockReadFrontBuffer(NPP instance)
> +{
> +PluginView* view = static_cast<PluginView*>(instance->ndata);
> +PluginViewPrivate* viewPrivate = view->getPrivate();
> +return viewPrivate->lockReadFrontBuffer();
> +}

... and here

ps: identation issue here!

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list