[Webkit-unassigned] [Bug 72456] [Inspector][FileSystem] Capture DOMFileSystem object

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 21 19:49:14 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=72456





--- Comment #22 from Taiju Tsuiki <tzik at chromium.org>  2011-11-21 19:49:13 PST ---
(From update of attachment 116015)
View in context: https://bugs.webkit.org/attachment.cgi?id=116015&action=review

>> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:59
>> +    // Store |fileSystem| and notify the frontend using |fileSystemAdded| event.
> 
> We are not using | | notation in WebKit.

Done.

>> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:98
>> +    m_frontend = 0;
> 
> You should clear the enabled state here:
> m_enabled = false;
> m_state->setBoolean(FileSystemAgentState::fileSystemAgentEnabled, m_enabled);
> 
> disconnecting front-end should end up in disabling instrumentation.

Done.

>> Source/WebCore/inspector/InspectorFileSystemAgent.h:53
>> +    void invalidateFileSystem(PassRefPtr<DOMFileSystem>);
> 
> fileSystemInvalidated? If this is a signal from WebCore, it should be named as event.

Done.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list