[Webkit-unassigned] [Bug 72456] [Inspector][FileSystem] Capture DOMFileSystem object

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 21 01:32:55 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=72456


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #116015|review?                     |review+
               Flag|                            |




--- Comment #20 from Pavel Feldman <pfeldman at chromium.org>  2011-11-21 01:32:54 PST ---
(From update of attachment 116015)
View in context: https://bugs.webkit.org/attachment.cgi?id=116015&action=review

> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:59
> +    // Store |fileSystem| and notify the frontend using |fileSystemAdded| event.

We are not using | | notation in WebKit.

> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:98
> +    m_frontend = 0;

You should clear the enabled state here:
m_enabled = false;
m_state->setBoolean(FileSystemAgentState::fileSystemAgentEnabled, m_enabled);

disconnecting front-end should end up in disabling instrumentation.

> Source/WebCore/inspector/InspectorFileSystemAgent.h:53
> +    void invalidateFileSystem(PassRefPtr<DOMFileSystem>);

fileSystemInvalidated? If this is a signal from WebCore, it should be named as event.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list