[Webkit-unassigned] [Bug 69870] [Chromium] Empty API for web intents

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 18 11:08:54 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=69870


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #115418|review?                     |review-
               Flag|                            |




--- Comment #12 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2011-11-18 11:08:53 PST ---
(From update of attachment 115418)
View in context: https://bugs.webkit.org/attachment.cgi?id=115418&action=review

> Source/WebKit/chromium/public/WebFrame.h:556
> +    virtual void replyFromIntentService(WebIntentsReplyType, const WebString&, int intentId) = 0;

How about calling this "handleIntentResult" or "handleIntentReply"?

> Source/WebKit/chromium/public/WebIntentServiceData.h:48
> +class WebIntentServiceData {

nit: "Info" might be a better suffix for this class.  See for example WebPopupMenuInfo.

> Source/WebKit/chromium/public/WebIntentServiceData.h:53
> +    WEBKIT_EXPORT void setUrl(const WebURL&);

nit: setUrl should be setURL per the style guide

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list