[Webkit-unassigned] [Bug 71854] Access key should work on all elements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 18 03:12:44 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=71854


Vineet Chaudhary (vineetc) <rgf748 at motorola.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #115586|0                           |1
        is obsolete|                            |
 Attachment #115776|                            |review?
               Flag|                            |




--- Comment #41 from Vineet Chaudhary (vineetc) <rgf748 at motorola.com>  2011-11-18 03:12:43 PST ---
Created an attachment (id=115776)
 --> (https://bugs.webkit.org/attachment.cgi?id=115776&action=review)
Updated Patch

(In reply to comment #40)
> (From update of attachment 115586 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=115586&action=review
> 
> > Source/WebCore/html/HTMLElement.cpp:777
> >  void HTMLElement::accessKeyAction(bool sendToAnyElement)
> 
> Per IRC discussion, we should rename this argument to sendMouseEvents or sendMouseDownAndMouseUp. r- because we definitely don't want to land the patch as is.

Done!

> > LayoutTests/fast/forms/access-key-for-all-elements.html:31
> > +    testElement.onclick = function () { debug(testElement.tagName + ' element was clicked.') };
> > +    testElement.onfocus = function () { debug(testElement.tagName + ' element was focused.') };
> 
> Instead of using debug here. You can do something like:
> 
> var clicked = false;
> testElement.onclick = function () { clicked = true; }
> var focused = false;
> testElement.onclick = function () { focused = true; }
> 
> shouldBe("pressKey(testElement.accessKey);[clicked, focused]", expected_value);
> 
> where expected_value is specific to each tagName.

Done!

As per the specification http://www.whatwg.org/specs/web-apps/current-work/multipage/commands.html#using-the-accesskey-attribute-on-a-label-element-to-define-a-command input, button, select.. have different behavior than other elements. eg. input element only gets focused on accessKey pressed.
To test the behavior of such elements we already have test case access-key.html. Added select and textArea to the same.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list