[Webkit-unassigned] [Bug 71854] Access key should work on all elements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 17 23:16:14 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=71854


Ryosuke Niwa <rniwa at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #115586|review?                     |review-
               Flag|                            |




--- Comment #40 from Ryosuke Niwa <rniwa at webkit.org>  2011-11-17 23:16:14 PST ---
(From update of attachment 115586)
View in context: https://bugs.webkit.org/attachment.cgi?id=115586&action=review

> Source/WebCore/html/HTMLElement.cpp:777
>  void HTMLElement::accessKeyAction(bool sendToAnyElement)

Per IRC discussion, we should rename this argument to sendMouseEvents or sendMouseDownAndMouseUp. r- because we definitely don't want to land the patch as is.

> LayoutTests/fast/forms/access-key-for-all-elements.html:31
> +    testElement.onclick = function () { debug(testElement.tagName + ' element was clicked.') };
> +    testElement.onfocus = function () { debug(testElement.tagName + ' element was focused.') };

Instead of using debug here. You can do something like:

var clicked = false;
testElement.onclick = function () { clicked = true; }
var focused = false;
testElement.onclick = function () { focused = true; }

shouldBe("pressKey(testElement.accessKey);[clicked, focused]", expected_value);

where expected_value is specific to each tagName.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list