[Webkit-unassigned] [Bug 72452] [Chromium] Avoid clear and color mask operations for root layers

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 16 15:43:55 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=72452


James Robinson <jamesr at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #115453|review?                     |review+, commit-queue-
               Flag|                            |




--- Comment #16 from James Robinson <jamesr at chromium.org>  2011-11-16 15:43:55 PST ---
(From update of attachment 115453)
View in context: https://bugs.webkit.org/attachment.cgi?id=115453&action=review

Daniel pointed out offline that he is eagerly initializing the non-swizzled program and lazily initializing the swizzled one, which matches what we currently do for other programs.

Could you please move removing the compositor blue clear to a separate patch? We've had difficulties with that bit in particular and it's not inherently related to the other changes.

> Source/WebCore/platform/graphics/chromium/LayerRendererChromium.cpp:397
> +#if !defined ( NDEBUG )

we tend to do #ifndef NDEBUG

> Source/WebCore/platform/graphics/chromium/ShaderChromium.h:185
> +    String getShaderString() const;

nit: this shouldn't have a "get" prefix, in WebKit style this function should be called 'shaderString()'.  It looks like everything else in this file uses the get prefix as well though.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list